Degraded Performance Affecting Some Samsung S8/S8+/Note 8 Devices
Incident Report for Orion Labs, Inc.
Resolved
This issue has been resolved. However, we will continue to monitor to ensure the best possible experience.
Posted over 1 year ago. May 01, 2018 - 14:07 PDT
Update
We are continuing to monitor for any further issues.
Posted over 1 year ago. May 01, 2018 - 13:59 PDT
Update
We are continuing to monitor for any further issues.
Posted over 1 year ago. May 01, 2018 - 13:59 PDT
Monitoring
There’s a new firmware update available for Onyx that will improve the audio issues for the affected Samsung devices. Simply download the latest version of the Orion app and then connect Onyx. The app will guide you through the firmware update process.
Posted over 1 year ago. Apr 24, 2018 - 10:31 PDT
This incident affected: Orion Voice Translation Service.