Translation Preview is Down
Incident Report for Orion Labs, Inc.
Resolved
Thank you for your patience. The Translation Preview feature is back online.
Posted Nov 18, 2019 - 14:38 PST
Update
We are working with our partners to resolve this situation. Thank you for your continued patience.
Posted Nov 12, 2019 - 16:38 PST
Identified
The issue has been identified. Your continued patience is appreciated while we work with our partners to resolve the situation.
Posted Oct 28, 2019 - 11:34 PDT
Investigating
We are currently investigating the issue. Customer production translation services are unaffected and available.
Posted Oct 22, 2019 - 09:56 PDT