Facebook Account Creation Error
Incident Report for Orion Labs, Inc.
Resolved
This incident has been resolved.
Posted 7 months ago. Oct 29, 2018 - 17:14 PDT
Investigating
We are currently experiencing an elevated error rate around account creation via Facebook.
Posted 7 months ago. Oct 29, 2018 - 15:15 PDT