Translator Bot is Offline
Incident Report for Orion Labs, Inc.
Resolved
We've identified the issue and Translation Bot is back online.
Posted 10 months ago. Jul 30, 2018 - 18:02 PDT
Investigating
The Orion Translator Bot is offline and we are currently working to identify the cause.
Posted 10 months ago. Jul 30, 2018 - 17:57 PDT
This incident affected: Orion Voice Translation Service.